Anyone Else Have trouble Saving their Journal Posts

For the fifth time in recent memory, I typed up my weekly recap and hit post, only to find that the post never happened. No error, just no post. Once I was able to "Create new post" and found it was all still saved, but it took clicking about 8 times to get the data to post.

Today I didn't catch it, however, and after an hour of typing, all of it's just...gone.

Anyone else have this happen... And if there's a way to avoid (outside of typing up a word doc and copy/pasting -- which is what I'm going to return to doing) please let me know.
Permalink
I have a similar issue when trying to update the race/role/level of a character listed under "My characters".

The page processes properly but no updated are applied. This only seems to apply under the "Basic Information" tab and not the "Details" tab.
Permalink
Apologies. This should be corrected
Permalink
I can confirm my post is resolved. Thanks for all the great work.
Permalink
Hm... the first time I click 'update' on any journal post I try to edit, I get a screen that tells me I can't post as both a character and an NPC but if I click the update button a second time it updates as whoever created the post... weird!

Just an FYI - know you're busy!
Permalink
Crinita
Hm... the first time I click 'update' on any journal post I try to edit, I get a screen that tells me I can't post as both a character and an NPC but if I click the update button a second time it updates as whoever created the post... weird!

Just an FYI - know you're busy!


same problem here
Permalink